Application Temporarily Down
Incident Report for BombBomb
Resolved
Engineers have identified and resolved this issue. The BombBomb application is back online!
Posted about 1 month ago. Oct 05, 2017 - 21:11 MDT
Investigating
Engineers are investigating a problem with the BombBomb application being unavailable and are working to resolve. The application should be available again shortly. Thanks for your patience.
Posted about 1 month ago. Oct 05, 2017 - 20:50 MDT