Delays with Sending and Report Generation
Incident Report for BombBomb
Resolved
This incident has been resolved.
Posted 11 months ago. Nov 09, 2016 - 07:25 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 11 months ago. Nov 09, 2016 - 06:32 MST