AWS Outage - Impacting Email Delivery

Incident Report for BombBomb

Resolved

AWS servers appear to be restored allowing for BombBomb email to be sending successfuly. We will continue to closely monitor.
Posted Oct 20, 2025 - 14:13 MDT

Identified

We have confirmed an AWS (Amazon Web Servers) outage is impacting BombBombs email processing infrastructure.
Posted Oct 20, 2025 - 10:20 MDT
This incident affected: Web Application and Email Delivery.