Bombbomb Classic

Incident Report for BombBomb

Resolved

This incident has been resolved, and our team will continue to monitor.
Posted Sep 26, 2025 - 11:06 MDT

Investigating

We are currently investigating an issue impacting features in BombBomb Classic Platform, including sending emails, video recorder, and our BombBomb extensions.
Posted Sep 26, 2025 - 10:53 MDT
This incident affected: Web Application, Chrome Extension, Video Recording, and Email Delivery.