Email Delivery Issue with Yahoo

Incident Report for BombBomb

Resolved

This incident has been resolved.
Posted Aug 08, 2024 - 07:17 MDT

Monitoring

Our teams have implemented a fix for this issue, and we will be closely monitoring our delivery.
Posted Aug 07, 2024 - 15:15 MDT

Investigating

Our team is actively investigating a mail delivery issue with Yahoo.
Posted Aug 07, 2024 - 10:59 MDT
This incident affected: Email Delivery.