System outage
Incident Report for BombBomb
Resolved
This incident has been resolved.
Posted Sep 19, 2023 - 14:38 MDT
Investigating
We are currently investigating an issue impacting our Web Application and causing an outage.
Posted Sep 19, 2023 - 14:30 MDT
This incident affected: WWW Site and Web Application.